3.6 Utilizar funciones

Aunque es importante presentar los datos de forma adecuada, lo fundamental en una hoja de cálculo es saber trabajar con ellos. Y aquí es donde cobran una gran importancia las funciones. Utilizar las funciones nos simplifica la escritura de fórmulas, a la vez que nos permite hacer cálculos mucho más potentes. Por eso, hay que estar familiarizado con los tipos de funciones que podemos utilizar en Google Docs.

Una función es una fórmula predefinida por Google Docs, que opera con uno o más valores y devuelve un resultado que aparecerá directamente en la celda o será utilizado para calcular la fórmula que la contiene.

La sintaxis de cualquier función es:

nombre_función(argumento1;argumento2;...;argumentoN)

Siguen las siguientes reglas:

  • En una fórmula, podemos utilizar una función igual que un valor o una referencia, por lo que si va al comienzo de una fórmula debe empezar por el signo =.
  • Los argumentos o valores de entrada van siempre entre paréntesis. No dejes espacios antes o después de cada paréntesis.
  • Los argumentos pueden ser valores constantes (número o texto), fórmulas o funciones.
  • Los argumentos deben de separarse por un punto y coma ;.

Ejemplo: =SUMA(A1:C8)

Tenemos la función SUMA() que devuelve como resultado la suma de sus argumentos. El operador ":" nos identifica un rango de celdas, así A1:C8 indica todas las celdas incluidas entre la celda A1 y la C8. Así la función anterior sería equivalente a:

=A1 + A2 + A3 + A4 + A5 + A6 + A7 + A8 + B1 + B2 + B3 + B4 + B5 + B6 + B7 + B8 + C1 + C2 + C3 + C4 + C5 + C6 + C7 + C8

En este ejemplo se puede apreciar la ventaja de utilizar la función.

Las fórmulas pueden contener más de una función, y pueden aparecer funciones anidadas dentro de la fórmula.

Ejemplo: =SUMA(A1:B4)/SUMA(C1:D4)

Existen muchos tipos de funciones dependiendo del tipo de operación o cálculo que realizan. Así hay funciones matemáticas, estadísticas, financieras, de texto, de fecha y hora, lógicas, de información, de búsqueda, de ingeniería, de información y funciones exclusivas creadas por Google.

Para introducir una fórmula debe escribirse en una celda cualquiera tal cual introducimos cualquier texto.